№ варианта Объем производства Потребление отраслей Спрос
1 1000 200 250 120 1000

600 150 50 40 1000

800 0 250 700 1000

Решение задачи
Определение вектора конечной продукции за предыдущий период
По условию задачи известны объемы производства каждой из отраслей за предыдущий период (суммарный выпуск продукции отрасли i): X1=1000, X2=600, X3= 800 и значения xij (i,j=1, 2, 3):

(1)

Отсюда, используя (1), можно определить значения Yi , i=1, 2, 3 конечной продукции каждой из отраслей за предыдущий период.
Y1=1000-200-250-120=430;
Y2=600-150-50-40=360;
Y3=800-0-250-700=-150.
Таким образом, вектор конечной продукции за предыдущий период найден: Вектор содержит отрицательное значение, матрица А непродуктивна.
Для определения вектора выпуска продукции Х при заданном конечном прогнозируемом векторе спроса надо решить систему уравнений
Х=АХ+Y, (2)
где — матрица прямых затрат;
, из которой следует, что
, (3)
где Е — единичная матрица
;
S=(E-A)-1 — называется матрицей полных затрат.

Определение коэффициентов прямых затрат
Учитывая, что технология производства не изменилась, определим коэффициенты прямых затрат aij:

Таким образом, матрица коэффициентов прямых затрат будет иметь вид
.
Проверка продуктивности матрицы
Все элементы матрицы А неотрицательные, А0.
Для того чтобы система уравнений (2) имела единственное неотрицательное решение при любом неотрицательном векторе Y, необходимо, чтобы матрица А была продуктивной. Экономический смысл продуктивности состоит в том, что существует такой план выпуска продукции, при котором каждая отрасль сможет произвести некоторое количество конечной продукции. Известно, что для продуктивности матрицы А0 необходимо и достаточно, чтобы все главные миноры матрицы (Е-А) были положительными числами, строго меньше единицы. Кроме того, если сумма элементов каждого из столбцов неотрицательной квадратной матрицы А положительна и строго меньше единицы, то все главные миноры матрицы (Е-А) положительны и строго меньше единицы.
Суммы элементов каждого столбца матрицы А соответственно равны:

Следовательно, в силу вышесказанного, матрица А непродуктивна, выражение (3) не имеет смысл и вектор Y отрицателен. Следовательно, для нахождения плана выпуска продукции Х нельзя воспользоваться формулой (3).

Реализация балансовой модели в электронной таблице (ЭТ) Excel
Компьютерная реализация балансовой модели в ЭТ показана в табл. 1 (режим показа формул) и в табл. 2 (режим вычислений).
В строке 11 размещены формулы для проверки продуктивности матрицы технологических коэффициентов. В ячейке А11 формула
=ИЛИ(В10>=1;C10>=1;D10>=1)
проверяет содержимое ячеек В10:D10. Если хотя бы в одной из этих ячеек значение больше единицы (т.е. сумма значений элементов хотя бы в одном столбце превышает единицу), то в ячейку А11 будет записано значение «ИСТИНА». В противном случае – значение «ЛОЖЬ».
В ячейку С11 введена формула
=ЕСЛИ(А11=ИСТИНА;”Решения нет”;”Матрица продуктивна”).
Эта формула проверяет содержимое ячейки А11 и если сумма элементов хотя бы одного столбца превысила единицу, выводит сообщение “Решения нет”, в противном случае – “Матрица продуктивна”.
Таблица 1. Балансовая модель. Режим показа формул

A B C D
1 БАЛАНСОВАЯ МОДЕЛЬ
2 Объём производства Потребление отраслей
3 1000 200 250 120
4 600 150 50 40
5 800 0 250 700
6 Вычисление технологических коэффициентов =B3/$A$3 =C3/$A$4 =D3/$A$5
7
=B4/$A$3 =C4/$A$4 =D4/$A$5
8
=B5/$A$3 =C5/$A$4 =D5/$A$5
9 Проверка продуктивности матрицы А
10
=СУММ(B6:B8)
=СУММ(C6:C8)
=СУММ(D6:D8)
11 =ИЛИ(В10>=1;С10>=1;D10>=1) =ЕСЛИ(А11=ИСТИНА;»Решения нет»; «Матрица продуктивна»)
12 Единичная матрица 1 0 0
13
0 1 0
14
0 0 1
15 Вычисление
Е-А =В12-В6 =C12-C6 =D12-D6
16
=В13-В7 =C13-C7 =D13-D7
17
=В14-В8 =C14-C8 =D14-D8
18 Вычисление обратной матрицы =МОБР(В15:D17) =МОБР(В15:D17) =МОБР(В15:D17)
19
=МОБР(В15:D17) =МОБР(В15:D17) =МОБР(В15:D17)
20
=МОБР(В15:D17) =МОБР(В15:D17) =МОБР(В15:D17)
21 Спрос на будущий период 1000 План выпуска продукции =МУМНОЖ(В18:D20;В21:В23)
22
1000
=МУМНОЖ(В18:D20;В21:В23)
23
1000
=МУМНОЖ(В18:D20;В21:В23)

Таблица 2. Балансовая модель. Режим показа вычислений

A B C D
1 БАЛАНСОВАЯ МОДЕЛЬ
2 Объём производства Потребление отраслей
3 1000 200 250 120
4 600 150 50 40
5 800 0 250 700
6 Вычисление технологических коэффициентов 0,2 0,416666667 0,15
7
0,15 0,083333333 0,05
8
0 0,416666667 0,875
9 Проверка продуктивности матрицы А
10
0,35 0,916666667 1,075
11 ИСТИНА Решения нет
12 Единичная матрица 1 0 0
13
0 1 0
14
0 0 1
15 Вычисление Е-А 0,8 -0,416666667 -0,15
16
-0,15 0,916666667 -0,05
17
0 -0,416666667 0,125
18 Вычисление обратной матрицы 1,621621622 1,981981982 2,738738739
19
0,324324324 1,72972973 1,081081081
20
1,081081081 5,765765766 11,6036036
21 Спрос на будущий период 1000 План выпуска продукции 6342,342342
22
1000
3135,135135
23
1000
18450,45045

№ варианта Объем производства Потребление отраслей Спрос 1 1000 200 250 120 1000 600 150 50 40 1000 800 0 250 700 1000 Решение задачи Определение